Network Outage in Bethany Hall
Incident Report for Seton Hall University
Resolved
The network issue in Bethany Hall has been resolved.
Posted Oct 10, 2019 - 11:24 EDT
Investigating
We are currently investigating a network outage in Bethany Hall.
Posted Oct 10, 2019 - 11:02 EDT
This incident affected: Network and Internet.