Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 28, 2025 - 23:30 EDT
Scheduled
The Department of Information Technology will be performing network maintenance on the South Orange campus from 11:30 p.m. on Saturday, June 28, until 1 a.m. on Sunday, June 29. While no service disruptions are anticipated during this period, please note that a brief 5- to 10-minute network outage may occur after 1 a.m.
Wireless Firmware Upgrades Upgrading our wireless systems will enhance functionality and provide improved support for our end users. This upgrade will provide newer software that introduces or enhances features we use daily to connect with each other on campus.
LAN Access Switch Firmware Upgrades One of the key components that drives the network is the LAN switches. These devices are essential for connecting our local networks to key host systems such as Banner, Canvas, and Microsoft Teams. Upgrading the firmware on these switches will improve network reliability, performance, and security, ensuring better connectivity and support for all campus activities.
If you experience any issues outside of the maintenance window, please contact the Technology Service Desk at (973) 275-2222 or servicedesk@shu.edu.
Posted May 28, 2025 - 15:39 EDT
This scheduled maintenance affected: Network and Internet.