Microsoft Teams Outage
Incident Report for Seton Hall University
Resolved
Microsoft has rebalanced user requests and confirmed that impact has been remediated. If you experience any issues, please open a ticket at www.shu.edu/servicedesk
Posted Feb 04, 2021 - 13:05 EST
Identified
Microsoft has identified a drop in availability for services that facilitate meeting join functionality. They are working to determine the next steps to remediate the impact.
Posted Feb 04, 2021 - 12:10 EST
Investigating
Microsoft is investigating an issue where some users may be unable to join a Teams meeting.
Posted Feb 04, 2021 - 11:53 EST
This incident affected: Microsoft Office 365.