Duo Two Factor Outage
Incident Report for Seton Hall University
Resolved
As of 11:01 a.m., Amazon has identified the root cause and has taken steps to restore connectivity. They have seen some improvement in the last few minutes but continue to work towards full recovery.
Posted Dec 15, 2021 - 11:21 EST
Investigating
Some users are experiencing problems logging in to PirateNet. Duo and Amazon AWS are investigating. If you are experiencing problems, please try again in a few minutes.
Posted Dec 15, 2021 - 11:00 EST
This incident affected: Duo Two Factor.