TouchNet, the University’s billing system, has been fully restored.
Users are now able to log in and access all services, including both student and administrative functions. This issue has been resolved.
Posted Apr 15, 2026 - 14:16 EDT
Update
We are continuing to investigate the TouchNet service issue.
At this time, TouchNet, the University’s billing system, is experiencing a partial outage. Students are able to access their accounts and make payments, while administrative access remains unavailable.
The vendor is aware of the issue and investigation is ongoing. We will share additional updates as more information becomes available.
Posted Apr 15, 2026 - 12:07 EDT
Investigating
TouchNet, the University’s billing system used by students and authorized users to view account balances and make payments, is currently experiencing an outage. Users are unable to log in at this time.
The vendor is aware of the issue and is actively investigating. An estimated time for resolution is not yet available.
We will provide updates as more information becomes available.