Compass Login and Search Issues
Incident Report for Seton Hall University
Resolved
This incident has been resolved.
Posted May 20, 2021 - 08:55 EDT
Investigating
Compass is temporarily experiencing login and search issues. Students and faculty may have trouble signing in and using the service. Updates will be posted shortly.
Posted May 19, 2021 - 09:58 EDT
This incident affected: Compass.