Microsoft Teams
Incident Report for Seton Hall University
Resolved
Microsoft determined that an authentication certificate had expired causing, users to have issues using the service. An updated certificate has been deployed.
Posted Feb 03, 2020 - 13:56 EST
Investigating
Microsoft is investigating an issue where users may be unable to access Microsoft Teams.
Posted Feb 03, 2020 - 09:27 EST
This incident affected: Microsoft Office 365.