Touchnet Service Disruption

Incident Report for Seton Hall University

Resolved

TouchNet has resolved the issue affecting application response times. Payment and account-related services are now operating normally.
Posted Aug 12, 2026 - 09:31 EDT

Update

TouchNet has resolved the issue previously affecting response times. Normal service has now been restored.
Posted Aug 12, 2026 - 09:29 EDT

Monitoring

TouchNet has reported improved application response times. While service performance has improved, the vendor continues to investigate the underlying cause and work toward a full resolution.

The University will continue to monitor the situation and provide updates as more information becomes available.
Posted Aug 11, 2026 - 16:55 EDT

Investigating

TouchNet, the University's payment processing system used by students and authorized users to view account balances, make payments, and receive refunds, is currently experiencing slow response times. Users may experience delays when accessing payment and account-related services.

TouchNet's technical teams are actively investigating and working to restore normal service. We will provide updates as more information becomes available.
Posted Aug 11, 2026 - 14:02 EDT
This incident affected: Touchnet.