Internet Disruption – South Orange Campus

Incident Report for Seton Hall University

Resolved

Internet connectivity has been restored in all affected buildings on the South Orange campus.

If you experience any further issues, please don't hesitate to contact the Technology Service Desk at (973) 275-2222 or servicedesk@shu.edu.
Posted Jun 16, 2025 - 14:52 EDT

Investigating

The South Orange campus is currently experiencing a networking issue that is impacting internet connectivity in the University Center, Rec Center, Corrigan Hall, Jubilee Hall, and Bayley Hall. The Department of Information Technology is actively working to identify the cause and restore connectivity as quickly as possible.

Further updates will be provided as more information becomes available.
Posted Jun 16, 2025 - 14:33 EDT
This incident affected: Network and Internet.