Self-Service Banner 9 Upgrade - Monday, March 20th
Incident Report for Seton Hall University
Resolved
Self-Service Banner 9 upgrade has been completed. To learn about the changes to Self-Service Banner Home and how to navigate Self-Service Banner 9 applications, visit https://www.shu.edu/technology/news/self-service-banner-9-upgrade.cfm.
Posted Mar 20, 2023 - 18:15 EDT
Investigating
The newest version of Banner has been implemented for General, Human Resources and Finance self-service applications. While the upgraded version of Banner features the same or similar functionality as the previous Banner 8 version, you will notice changes to Self-Service Banner Home. Self-Service Banner’s interface has been modernized to offer easier navigation and a more intuitive user experience.

You will continue to log into Self-Service Banner through PirateNet using your Seton Hall credentials. To learn about the changes to Self-Service Banner Home and how to navigate Self-Service Banner 9 applications, visit https://www.shu.edu/technology/news/self-service-banner-9-upgrade.cfm.
Posted Mar 20, 2023 - 09:42 EDT
This incident affected: Banner.