Issues with Compass Advisor List
Incident Report for Seton Hall University
Resolved
The Compass advisor outage issue has been resolved.
Posted Sep 09, 2019 - 16:03 EDT
Investigating
We are currently investigating an issue with the advisor list in Compass.
Posted Sep 06, 2019 - 09:36 EDT
This incident affected: Compass.