Blackboard Outage
Incident Report for Seton Hall University
Resolved
Service has been restored.
Posted Nov 04, 2021 - 00:41 EDT
Investigating
Blackboard is experiencing issues and is working to restore functionality.
Posted Nov 03, 2021 - 23:35 EDT