TouchNet Outage
Incident Report for Seton Hall University
Resolved
TouchNet services have been restored. We will continue to monitor performance to ensure ongoing stability.
Posted Oct 18, 2024 - 18:59 EDT
Investigating
TouchNet, the university's payment processing system is experiencing an outage. As a result, users are currently unable to submit online payments. The vendor is aware of the issue and actively working to restore services.
Posted Oct 18, 2024 - 17:19 EDT