Cloudflare Outage Impacting Website Access

Incident Report for Seton Hall University

Resolved

Cloudflare has implemented a fix and web functionality has been restored. Systems have remained stable for the past two hours, and our IT team will continue to monitor performance to ensure ongoing reliability.
Posted Nov 18, 2025 - 12:14 EST

Monitoring

Cloudflare has implemented a fix and Seton Hall website functionality has been restored. Our team will continue to monitor the recovery of services for ongoing stability.
Posted Nov 18, 2025 - 10:17 EST

Identified

A global outage affecting Cloudflare is disrupting access to several of the University’s web properties, as well as many other websites worldwide. The issue originated with Cloudflare’s infrastructure and was not specific to our systems.

Cloudflare has identified the issue and a fix is being deployed to restore services. Our IT team is actively monitoring the situation and working to minimize any impact on University services.

During this service interruption, you can go directly to http://shu.okta.com to log in to Canvas, Banner, the University Portal, and other web applications.
Posted Nov 18, 2025 - 09:13 EST
This incident affected: Seton Hall Website.