NuPark (Parking Services) is temporarily unavailable.
Incident Report for Seton Hall University
Resolved
NuPark testing has concluded and the service is now available for use.
Posted Aug 09, 2019 - 08:57 EDT
Monitoring
The NuPark (Parking Services) chiclet in PirateNet is temporarily unavailable due to testing of Fall permits. NuPark should be available later this week.
Posted Aug 05, 2019 - 15:41 EDT