Partial Outage to Microsoft Outlook Email
Incident Report for Seton Hall University
Resolved
After a period of extended monitoring, Microsoft has confirmed that the issue impacting Outlook email access is resolved.
Posted Jul 18, 2022 - 12:36 EDT
Monitoring
Microsoft has implemented a fix for the Outlook performance issues. Microsoft has entered a period of extended monitoring to ensure the issue is resolved.
Posted Jul 18, 2022 - 12:11 EDT
Identified
Microsoft Outlook, the university's vendor for email is experiencing an outage. Users may be unable to access or use outlook services or features.
Posted Jul 18, 2022 - 11:34 EDT
This incident affected: Microsoft Office 365.