Partial Printing Outage
Incident Report for Seton Hall University
Resolved
The issue affecting printing services on the South Orange campus has been resolved. Access to printers and printing services for all users on campus can resume as normal.
Posted Aug 17, 2022 - 08:55 EDT
Identified
The South Orange campus is currently experiencing a partial outage to printing. As a result faculty, admin, and staff may be unable to use select printers on campus.

Our printing partners are currently working to have print services restored as soon as possible.
Posted Aug 16, 2022 - 14:29 EDT
This incident affected: Blueprint.