Partial Printing Outage
Incident Report for Seton Hall University
Resolved
Our printing partners have put fixes in place to resolve the issues affecting printing for the majority of users on the South Orange and Law campus.

The Department of Information Technology will communicate further changes to printing services through the system status page. If you need any assistance regarding printing, please reach out to servicedesk@shu.edu.
Posted Aug 18, 2022 - 20:31 EDT
Update
The Department of Information Technology continues to monitor printing issues on both the South Orange and Law campus. As our printing partners roll out the fix, there may be temporary outages to printing services.
Posted Aug 18, 2022 - 14:58 EDT
Update
Our printing partners have applied a fix to resolve the issue affecting printing on both the South Orange and Law Campus. While printing can now resume as normal, the Department of Information Technology will be monitoring print services to ensure stability for users on campus.
Posted Aug 18, 2022 - 09:03 EDT
Monitoring
Our printing partners are implementing a fix to have print services restored as soon as possible. Printing capabilities may be intermittent as this fix is deployed. The Department of Information Technology is monitoring the progress and will update the status when the issue is fully resolved.
Posted Aug 17, 2022 - 16:49 EDT
Investigating
The South Orange Campus and Law Campus are currently experiencing a partial outage to printing. This is an extension of the previous outage affecting printing services.

As a result faculty, admin, and staff may be unable to use select printers on campus.

Our printing partners are currently working to have print services restored as soon as possible.
Posted Aug 17, 2022 - 14:32 EDT
This incident affected: Blueprint.