Partial Canvas Outage
Incident Report for Seton Hall University
Resolved
The Canvas issue has been resolved and functionality has been fully restored.

If you continue to experience issues with Canvas, please contact the Technology Service Desk at (973) 275-2222 or servicedesk@shu.edu.
Posted Dec 20, 2023 - 10:48 EST
Investigating
Canvas is experiencing an issue affecting access to Fall 2023 and Spring 2024 courses for all users. The Department of Information Technology is working with the vendor to restore functionality.
Posted Dec 20, 2023 - 08:42 EST
This incident affected: Canvas.