The intermittent access issues affecting Canvas have been resolved. Canvas is now fully operational.
If you experience any further issues accessing Canvas, please contact the Technology Service Desk at (973) 275-2222 or servicedesk@shu.edu.
Posted Aug 31, 2026 - 19:21 EDT
Monitoring
Instructure has implemented a fix for the intermittent Canvas access issues and is monitoring the results. We will continue to provide updates as more information becomes available.
Posted Aug 31, 2026 - 16:32 EDT
Investigating
Some users may experience intermittent issues accessing Canvas and may receive a message indicating that the website is under heavy load before the request times out.
Instructure, the vendor that provides Canvas, is aware of the issue and is actively investigating. The Division of Information Technology is monitoring the situation and will provide updates as more information becomes available.