Degraded Performance: Microsoft 365 Services

Incident Report for Seton Hall University

Update

Microsoft reports continued improvements in service availability as it adjusts how traffic is handled across its systems. Microsoft is actively monitoring performance and making targeted changes to restore stability and ensure reliable service. We are monitoring the situation and will provide updates as they become available.
Posted Jan 22, 2026 - 22:15 EST

Update

Some members of the Seton Hall community may continue to experience degraded performance or intermittent access issues with Microsoft 365 services, including Outlook email, Microsoft Teams, OneDrive and SharePoint. Impacts may include difficulty sending or receiving email, reduced functionality in Microsoft Teams, slower or limited access to files in OneDrive or SharePoint, and intermittent issues accessing certain Microsoft 365 administrative or collaboration features.

Microsoft is actively working to stabilize its systems and restore normal service. We are monitoring the situation and will provide updates as they become available.
Posted Jan 22, 2026 - 20:08 EST

Identified

Some members of the Seton Hall community may be experiencing degraded performance or intermittent access issues with Microsoft 365 services, including Outlook email, Microsoft Teams, OneDrive and SharePoint.

Microsoft has identified the cause as an issue within a portion of its North America service infrastructure and is actively working to restore full service. We are monitoring the situation and will provide updates as they become available.
Posted Jan 22, 2026 - 16:29 EST
This incident affects: Microsoft Office 365.