AWS Outage Impacting Multiple Services

Incident Report for Seton Hall University

Resolved

Services have been restored.
Posted Oct 21, 2025 - 07:32 EDT

Monitoring

We are continuing to monitor the recovery of services impacted by the earlier AWS outage. Functionality has been restored for the affected platforms, and we are observing for ongoing stability.

We will provide further updates if the situation changes.
Posted Oct 20, 2025 - 20:49 EDT

Update

We are actively monitoring the ongoing AWS outage, which is currently affecting several services, including Canvas and Ellucian platforms. We will continue to provide updates as more information becomes available.
Posted Oct 20, 2025 - 16:52 EDT

Update

We are actively monitoring the ongoing Canvas performance issues and the effects of the AWS outage. We will share updates as more information becomes available.
Posted Oct 20, 2025 - 16:18 EDT

Identified

The Department of Information Technology is monitoring a service disruption affecting Canvas due to a widespread Amazon Web Services (AWS) outage.

While the system remains available, some Canvas features may experience degraded performance. The vendor is actively working to resolve the issue, and we will provide updates as they become available.

You can follow the official status of the issue on the Instructure Status Page:https://status.instructure.com/
Posted Oct 20, 2025 - 13:05 EDT
This incident affected: Canvas.