University Portal Degraded Performance

Incident Report for Seton Hall University

Resolved

Normal system performance has been restored.

If cards you previously pinned are missing from your homepage, you can re-pin them by following these steps:

How to Pin/Unpin Cards to Your Homepage:
https://servicedesk.shu.edu/space/PUBLICKBA/3506831361/How+to+Pin%2FUnpin+Cards+to+your+Homepage
Posted Dec 11, 2025 - 23:23 EST

Identified

Ellucian engineers are working to resolve an issue where some users' University Portal cards are not appearing in their dashboard. We will continue to provide updates as they become available.
Posted Dec 11, 2025 - 14:17 EST

Investigating

We are aware of a temporary issue in University Portal where some cards may not appear on your homepage, and previously pinned cards may have disappeared. In many cases, refreshing the page restores the cards in their respective tabs.

If cards you previously pinned are missing from your homepage, you can re-pin them by following these steps:

How to Pin/Unpin Cards to Your Homepage:
https://servicedesk.shu.edu/space/PUBLICKBA/3506831361/How+to+Pin%2FUnpin+Cards+to+your+Homepage

We are monitoring the situation and will provide updates as information becomes available.
Posted Dec 11, 2025 - 11:16 EST
This incident affected: University Portal.