PirateNet Applications Performance Issues

Incident Report for Seton Hall University

Resolved

The performance issues affecting access to applications through PirateNet have been resolved.

If you continue to experience any issues, please contact the Technology Service Desk for further assistance.
Posted Aug 18, 2025 - 16:22 EDT

Monitoring

Remediation actions have been implemented to address the performance issues affecting access through PirateNet. Application latency and response times are showing improvement, and work is continuing to fully restore normal service. Further updates will be shared as they become available.
Posted Aug 18, 2025 - 14:19 EDT

Investigating

The Department of Information Technology has become aware of performance issues affecting access to applications through PirateNet. Users may experience slow load times or encounter error messages when attempting to log in.

The Department is actively working with service providers to identify the cause and implement a resolution. Updates will be shared as more information becomes available.
Posted Aug 18, 2025 - 13:17 EDT
This incident affected: Okta Single Sign On and University Portal.