Microsoft 365 Service Disruption

Incident Report for Seton Hall University

Resolved

Microsoft has confirmed that all services have been fully restored.
Posted Mar 01, 2025 - 20:13 EST

Monitoring

Microsoft suspects they have identified the cause of the issue and have applied a fix. They are now monitoring system performance to confirm full restoration of services. Normal functionality is expected to return soon.
Posted Mar 01, 2025 - 17:02 EST

Investigating

The Department of Information Technology is aware of a potential issue affecting some users' access to Microsoft 365 services. Microsoft is currently investigating the issue and assessing its impact. We will provide an update as soon as more information becomes available.
Posted Mar 01, 2025 - 16:50 EST
This incident affected: Microsoft Office 365.