Employee Printing Unavailable
Incident Report for Seton Hall University
Resolved
Employee printing services have been restored.
Posted Mar 02, 2021 - 15:24 EST
Investigating
We are currently investigating an issue with employee printing. At this time employees are unable to print.
Posted Mar 02, 2021 - 13:43 EST
This incident affected: Blueprint.