SafeAssign Backlog
Incident Report for Seton Hall University
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 11:53 EST
Monitoring
Due to the high load of submissions to SafeAssign, there is a backlog for processing. The expected waiting time is around 6 hours.
Posted Nov 23, 2020 - 09:31 EST
This incident affected: Blackboard.