Partial Outage to Microsoft Outlook Email
Incident Report for Seton Hall University
Resolved
Microsoft has confirmed that access to Outlook on the web and other Microsoft services and features has been restored. Monitoring of service health will continue while they analyze system logs to determine the cause of the problem.
Posted Jun 05, 2023 - 21:02 EDT
Monitoring
Microsoft has implemented a fix for the Outlook performance issues. Microsoft has entered a period of extended monitoring to ensure the issue is resolved.
Posted Jun 05, 2023 - 14:37 EDT
Investigating
Microsoft Outlook, the university's vendor for email is experiencing an outage. Users may be unable to access Outlook on the web or use the search functionality within Outlook.
Posted Jun 05, 2023 - 11:38 EDT
This incident affected: Microsoft Office 365.