Blackboard Outage
Incident Report for Seton Hall University
Resolved
The Blackboard outage has been resolved. Service should be fully restored.
Posted Oct 07, 2019 - 18:44 EDT
Investigating
Blackboard is experiencing issues and is working to restore functionality.
Posted Oct 07, 2019 - 18:18 EDT
This incident affected: Blackboard.