Printing Outage
Incident Report for Seton Hall University
Resolved
The outage to printing experienced on the Law and South Orange campuses has been resolved. Printers on both campuses are now back online and users can resume normal printing operations.

If experiencing slow connections, our printing partners have recommended restarting the printers.
Posted Sep 07, 2022 - 16:38 EDT
Monitoring
Printing service and performance on the Law and South Orange campus may still be intermittent. The Department of Information Technology is monitoring the situation with our printing partners and will update once the issue is fully resolved.
Posted Sep 07, 2022 - 10:31 EDT
Update
The Law and South Orange Campuses are experiencing a printing outage.

The Department of Information Technology is currently working with our printing partners on a solution to the issue.
Posted Sep 06, 2022 - 12:13 EDT
Identified
The University is currently experiencing an outage to printing services on campus. As a result, users may be unable to use select printers on campus.

Our printing partners are currently working to have print services restored as soon as possible.
Posted Sep 06, 2022 - 11:40 EDT
This incident affected: Blueprint.