Scheduled Infoblox DNS/DHCP Appliance Maintenance: Monday, June 22

Scheduled for Jun 22, 05:00 - 10:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 14, 2026 - 15:21 EDT

Scheduled

The Department of Information Technology will be performing upgrades to the Infoblox DNS/DHCP appliances at the South Orange and IHS campuses on Monday, June 22, 2026, beginning at 5 p.m.

While no outage is expected during the maintenance window, users may experience slower DNS query response times or intermittent delays accessing websites and online services.

If you experience any issues outside of the maintenance window, please contact the Technology Service Desk at (973) 275-2222 or servicedesk@shu.edu.
Posted May 14, 2026 - 15:19 EDT