Banner Maintenance: Tuesday, July 14 at 9 a.m.

Scheduled for Jul 14, 09:00 - 11:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 09, 2026 - 15:08 EDT

Scheduled

The Division of Information Technology will apply a critical security patch to Banner on Tuesday, July 14, beginning at 9 a.m. The maintenance is expected to take approximately two hours.

During this maintenance window, the following services will be temporarily unavailable:

Anonymous Grading for the Law School
Becoming a Pirate
Campus Directory
eRefund
Non-Instructional Release Requests
Technology Service Desk Identity Verification
Student FERPA Authorization Form
NJ Transit Tickets
Tuition Remission Form
Insurance Waiver

If you experience technology issues after the maintenance is complete, please contact the Technology Service Desk at (973) 275-2222.
Posted Jul 09, 2026 - 11:18 EDT
This scheduled maintenance affects: Banner.