Microsoft Outage affecting Outlook, Teams, and Office365 Services
Incident Report for Seton Hall University
Resolved
The mitigation strategy by Microsoft was successful in allowing users to sign into the previously impacted services. Microsoft internal monitoring has validated this recovery and have received positive confirmation from customer reports.
Posted Sep 28, 2020 - 21:43 EDT
Identified
Microsoft is rerouting traffic to alternate infrastructure to improve the user experience while they continue to investigate the issue.

Users are unable to access Outlook.com, Microsoft Teams including Teams Live Events, and Office.com. Additionally, Power Platform and Dynamics365 properties are affected by this incident.

Existing customer sessions are not impacted and any user who is logged in to an existing session would be able to continue their sessions.
Posted Sep 28, 2020 - 19:58 EDT
Investigating
Microsoft is investigating an issue affecting access to multiple Microsoft 365 services. We're working with Microsoft to identify the full impact and will provide more information shortly.
Posted Sep 28, 2020 - 18:59 EDT
This incident affected: Microsoft Office 365.