Banner Outage
Incident Report for Seton Hall University
Resolved
Banner services have been restored.
Posted Jan 21, 2025 - 12:45 EST
Monitoring
The Department of Information Technology has identified the root cause of the issue and will continue to monitor service stability. During this time, access to Banner may remain intermittent.
Posted Jan 21, 2025 - 12:28 EST
Investigating
Access to Banner, the University’s primary system for student, finance, and HR operations, is currently unavailable. This outage is impacting all Banner services, including Banner Admin Pages, Banner Self-Service (which encompasses Student, Employee, and Faculty Banner Self-Service links and Banner Page Builder applications), as well as third-party applications such as Axiom and Workflow.

The Department of Information Technology is actively investigating the issue and working to restore services as quickly as possible.
Posted Jan 21, 2025 - 11:47 EST
This incident affected: Banner.