Microsoft has confirmed that service availability remains stable and healthy. They will continue extended monitoring and optimize the environment to resolve any remaining impacts.
If you experience any further issues, please don't hesitate to contact the Technology Service Desk at (973) 275-2222 or servicedesk@shu.edu.
Posted Nov 26, 2024 - 08:28 EST
Monitoring
Microsoft has reported that service is gradually recovering and anticipates full resolution by Monday, November 25, 2024, at 10 p.m. EST. They are closely monitoring the progress and will provide updates if the timeline changes.
Posted Nov 25, 2024 - 19:53 EST
Identified
We are aware of an issue causing degraded performance across multiple Microsoft services, including Exchange Online, Microsoft Teams, and SharePoint Online. Microsoft is actively investigating the situation and we will provide more information, including an estimated time to resolution, as soon as it becomes available.