Compass is currently unavailable

Incident Report for Seton Hall University

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 12:08 EDT

Investigating

The Department of Information Technology is aware that EAB Compass is experiencing a service disruption for Seton Hall users. Our team is working with the vendor to resolve the issue. We will provide updates as more information becomes available.
Posted Aug 25, 2025 - 10:47 EDT
This incident affected: Compass.