Compass is experiencing limited functionality

Incident Report for Seton Hall University

Resolved

The issues with Compass have been resolved.
Posted Dec 17, 2019 - 09:57 EST

Update

We are continuing to investigate this issue.
Posted Dec 16, 2019 - 16:27 EST

Investigating

We are currently investigating this issue.
Posted Dec 16, 2019 - 16:05 EST
This incident affected: Compass.