Outlook Outage
Incident Report for Seton Hall University
Resolved
This incident has been resolved.
Posted May 11, 2021 - 21:57 EDT
Monitoring
Microsoft has identified the root cause and are applying a fix, which will reach affected users over the next 3 to 4 hours. Users will need to restart the Outlook client to apply the fix after it's received. We expect service to be restored by 11 p.m.
Posted May 11, 2021 - 19:18 EDT
Investigating
Microsoft is investigating an issue with email message visibility in Outlook. Outlook on the web and Outlook Mobile appear to be unaffected.
Posted May 11, 2021 - 17:43 EDT
This incident affected: Microsoft Office 365.