Seton Hall Website Outage

Incident Report for Seton Hall University

Resolved

Access to the Seton Hall University website has been restored. The Division of Information Technology continues to investigate the cause of the outage and is monitoring the website for any further issues.
Posted Sep 02, 2026 - 17:11 EDT

Investigating

The Seton Hall University website is currently unavailable. The Division of Information Technology is aware of the issue and is actively working to restore access.

We will provide updates as more information becomes available.
Posted Sep 02, 2026 - 17:06 EDT
This incident affected: Seton Hall Website.