Touchnet Service Disruption

Incident Report for Seton Hall University

Resolved

The issue affecting payments submitted through TouchNet has been resolved. If you continue to experience issues submitting a payment, please contact the Technology Service Desk.
Posted Sep 20, 2026 - 20:58 EDT

Investigating

TouchNet, the University's payment system, is currently experiencing an issue that may cause submitted payments to fail.

TouchNet is aware of the issue and is actively working to restore normal service. We will provide updates as more information becomes available.
Posted Sep 20, 2026 - 20:00 EDT
This incident affected: Touchnet.