Canvas Degraded Performance

Incident Report for Seton Hall University

Resolved

This issue has been resolved.
Posted Nov 07, 2025 - 15:00 EST

Monitoring

Some users may have experienced slow load times or timeout errors when accessing Canvas. Instructure has identified the issue and implemented a fix. We will continue to monitor performance to ensure full restoration.

If you continue to experience issues, please contact the Seton Hall University IT Service Desk at (973) 275-2222 or email servicedesk@shu.edu for further assistance.
Posted Nov 07, 2025 - 12:08 EST
This incident affected: Canvas.