Duo Two Factor Outage
Incident Report for Seton Hall University
Resolved
Duo Two Factor authentication functionality has been restored.
Posted Aug 21, 2023 - 15:24 EDT
Monitoring
Duo has implemented a fix to restore functionality. While the Duo Prompt may experience a slight delay when loading, users should now be able to log into PirateNet and other Seton Hall systems. The vendor will continue to work towards full recovery.
Posted Aug 21, 2023 - 13:27 EDT
Identified
Duo has identified the issue causing authentication slowness and failures to load the Duo Prompt, and are working toward resolution.
Posted Aug 21, 2023 - 10:54 EDT
Investigating
Users are experiencing issues logging in to PirateNet due to an outage with Duo Two Factor. Users may receive the following error message, "System under heavy load. Please wait a few minutes and try again." Duo is investigating the issue to restore functionality.
Posted Aug 21, 2023 - 09:45 EDT
This incident affected: Duo Two Factor.