Microsoft Teams Outage
Incident Report for Seton Hall University
Resolved
Microsoft is rolling out a fix. Users should begin seeing recovery at this time. Full service is expected to be restored within the next 60 minutes.
Posted Mar 15, 2021 - 17:25 EDT
Update
Microsoft reports encountering some technical difficulties while rolling back the problematic update. They're working on resolving those issues while exploring additional remediation options in parallel. We'll provide an updated ETA on resolution as soon as one is available.
Posted Mar 15, 2021 - 16:46 EDT
Identified
Microsoft identified an issue with a recent change to the authentication system. They’re rolling back the update now to mitigate impact, which we expect will take approximately 15 minutes.
Posted Mar 15, 2021 - 16:15 EDT
Investigating
Microsoft is investigating an issue for access to multiple Microsoft 365 services, including Teams. Initial reports indicate that primary impact is to Microsoft Teams; however, other services including Exchange Online and Yammer are also impacted.
Posted Mar 15, 2021 - 16:01 EDT
This incident affected: Microsoft Office 365.