Banner 9 Vulnerability Patch
Incident Report for Seton Hall University
Resolved
Access to all impacted services has been restored.

Registration will remain in the Banner 8 version until further notice. If you have questions about registration, please email registrar@shu.edu.

If you experience any other technology issues, you may open a ticket, schedule a drop-off for hardware repair, or live chat with a technician at www.shu.edu/servicedesk or 24/7 at (973) 275-2222.
Posted Dec 08, 2022 - 16:05 EST
Update
Access to the following services has been restored:

Non-Instructional Release Requests
Student FERPA Authorization form
eRefund

The Department of Information Technology is actively working on resolving access issues for all impacted services.
Posted Dec 02, 2022 - 16:00 EST
Update
The Department of Information Technology has applied all of the available patches to the Banner 9 system. Access to the following service has been restored and monitoring of service stability will continue.

Technology Service Desk ability to verify identity

The Department of Information Technology continues to work on restoring access to the services below:

Anonymous Grading for the School of Law
Becoming a Pirate
eRefund
Non-Instructional Release Requests
Campus Directory on the web
Student FERPA Authorization form

Additionally, Banner services within the SHUmobile app, including profile and course information, are inaccessible at this time. Non-banner services within the app, such as the SHUFLY Shuttle tracking, are still operational. Full functionality of the SHUmobile app is expected to be restored on Wednesday, December 7, 2022.
Posted Dec 02, 2022 - 13:27 EST
Identified
The University has been made aware of security vulnerabilities in the Banner 9 system, provided to the University by Ellucian.

On Friday, December 2, 2022 at 9:00 a.m., the Department of Information Technology will begin to apply available emergency patches to address the issue.

The implementation of these security patches may affect the availability of the following services:

Anonymous Grading for the School of Law
Becoming a Pirate
Campus Directory on the web
eRefund
Non-Instructional Release Requests
Technology Service Desk ability to verify identity
Student FERPA Authorization form

We expect these services to be restored on or before Monday, December 5, 2022.

In addition to the above services being temporarily unavailable, the University will revert our course registration pages to the Banner 8 version. While the registration system will look different, the functionality will remain the same. Students will be able to register for the Winter and Spring 2023 semesters, edit their schedule by adding and dropping courses, and place their names on course waitlists.

As there is not a security patch available for our version of Banner 9 registration, the Banner 8 registration system will remain in place until a fix is released by Ellucian. If you have questions about registration, please email registrar@shu.edu.

If you experience any other technology issues, you may open a ticket, schedule a drop-off for hardware repair, or live chat with a technician at www.shu.edu/servicedesk or 24/7 at (973) 275-2222.
Posted Dec 01, 2022 - 19:14 EST
This incident affected: Banner.