NuPark (Parking Services) is temporarily unavailable.
Incident Report for Seton Hall University
Resolved
This incident has been resolved.
Posted Jan 10, 2020 - 18:35 EST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2020 - 14:31 EST