Microsoft Teams Call Routing Issue

Incident Report for Seton Hall University

Resolved

Microsoft has confirmed that service is restored and impact has been fully remediated.
Posted Mar 03, 2025 - 16:03 EST

Monitoring

Microsoft has deployed a configuration update to address the issue affecting Teams-provisioned auto attendants and call queues, which caused inbound calls to certain department main numbers to receive a busy signal. Initial results show improvements, and Microsoft is actively monitoring the situation to confirm the fix is fully mitigating the impact.
Posted Mar 03, 2025 - 15:40 EST

Investigating

Microsoft is investigating an issue affecting Teams-provisioned auto attendants and call queues, which may result in inbound calls to department main numbers—such as Enrollment, Health Services, CAPS, and DDS—receiving a busy signal. We will provide updates as soon as more information becomes available.
Posted Mar 03, 2025 - 14:29 EST
This incident affected: Microsoft Office 365.