Duo Two-Factor Call and Text Disruption

Incident Report for Seton Hall University

Resolved

Duo has confirmed that all services have been fully restored.
Posted Feb 13, 2025 - 21:13 EST

Identified

Duo is currently experiencing an issue affecting phone call and text message (SMS) authentication. If you rely on these methods to log in, you may experience delays or failures. While Duo is actively working on a resolution, please use an alternative method:
🔹 Duo Push Notification – Open the Duo Mobile app and approve the login request.
🔹 Passcode from Duo Mobile App – Open the app and enter a generated passcode.

For more details on authentication methods, visit: https://www.shu.edu/technology/duo-two-factor-updating-devices.html
Posted Feb 13, 2025 - 14:09 EST
This incident affected: Duo Two Factor.