Microsoft 365 Outage
Incident Report for Seton Hall University
Resolved
Microsoft has identified a DNS issue and has rerouted traffic. Although investigation of the cause of the DNS issue continues, services are beginning to recover. If you continue to experience issues relating to Microsoft services, please contact the Service Desk by opening a ticket at www.shu.edu/servicedesk
Posted Apr 01, 2021 - 19:00 EDT
Investigating
Microsoft is investigating an issue in which users may be unable to access Microsoft 365 services and features.
Posted Apr 01, 2021 - 18:08 EDT
This incident affected: Microsoft Office 365.