Outage Affecting Amazon WorkSpaces, AppStream, Echo360, and Service Desk Calls
Incident Report for Seton Hall University
Resolved
Amazon have mitigated the underlying issue and are seeing improvement in availability across most AWS services. All services are now independently working through service-by-service recovery.
Posted Dec 07, 2021 - 21:36 EST
Update
The root cause of this issue is an impairment of several network devices in the US-EAST-1 Region. Amazon is pursuing multiple mitigation paths in parallel, and have seen some signs of recovery, but do not have an ETA for full recovery at this time.
Posted Dec 07, 2021 - 15:00 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 07, 2021 - 13:06 EST
Update
An issue has been identified that is impacting functionality related to Blackboard Ally. Blackboard is working with AWS to resolve.
Posted Dec 07, 2021 - 13:06 EST
Update
Amazon is seeing impact to multiple AWS APIs in the US-EAST-1 Region. This issue is also affecting some of their monitoring and incident response tooling, which is delaying the ability to provide updates. They have identified the root cause and are actively working towards recovery.
Posted Dec 07, 2021 - 13:05 EST
Update
The outage also affects Echo360, the university's lecture capture service.
Posted Dec 07, 2021 - 11:47 EST
Investigating
Amazon Web Services (AWS), the university's vendor for cloud computing services is experiencing an outage. As a result, the Technology Service Desk phone, Amazon WorkSpaces, and AppStream access is affected.

Calls to the Service Desk and the main university phone number may not complete. The Department of Information Technology is working to temporarily redirect Service Desk calls to an alternate number. Users with an existing WorkSpace session should not be affected.
Posted Dec 07, 2021 - 11:32 EST
This incident affected: Amazon WorkSpaces and AppStream.