Canvas Outage

Incident Report for Seton Hall University

Monitoring

Canvas has been restored and is accessible via both the web and mobile app. Instructure continues to work on resolving issues affecting certain third-party integrations within Canvas.

The following integrations are currently impacted:

ALEKS
Cengage LTI
Honorlock
LinkedIn Learning
McGraw Hill Connect LTIA
McGraw Hill SIMnet LTIA
Stukent
ThingLink
Tutor.com

We are continuing to monitor the situation and will provide additional updates as more information becomes available.
Posted May 07, 2026 - 23:26 EDT

Investigating

Instructure, the parent company of the Canvas learning management system, has reported that Canvas is currently unavailable on both the web and mobile app. They are actively investigating the issue, and we are closely monitoring the situation. Additional information will be provided as it becomes available.
Posted May 07, 2026 - 16:50 EDT
This incident affects: Canvas.